summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-05 21:02:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-18 21:09:33 +0100
commit194d8e51cf43b697914c5a1b78dda77fd4adb886 (patch)
tree4ba9359f71bbfbe43a887c4a430e0ba48e7ce48d /gnu
parent8c6d24d388bcd72b595b5293c7afc6e06bde941b (diff)
gnu: Add packages/python-graphics module.
* gnu/packages/python-graphics.scm: New file. * gnu/local.mk: Add gnu/packages/python-graphics.scm to the scope. Change-Id: I1d077c838ff1c3c014c3d699b539eaf8befd5084
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/python-graphics.scm28
2 files changed, 29 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 81031c9bdd..89a795bfbd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -562,6 +562,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/python-check.scm \
%D%/packages/python-compression.scm \
%D%/packages/python-crypto.scm \
+ %D%/packages/python-graphics.scm \
%D%/packages/python-science.scm \
%D%/packages/python-web.scm \
%D%/packages/python-xyz.scm \
diff --git a/gnu/packages/python-graphics.scm b/gnu/packages/python-graphics.scm
new file mode 100644
index 0000000000..ef981bd8d7
--- /dev/null
+++ b/gnu/packages/python-graphics.scm
@@ -0,0 +1,28 @@
+;;; GNU Guix --- Functional package management for GNU
+
+(define-module (gnu packages python-graphics)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module ((guix build-system python) #:select (pypi-uri))
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-xyz))
+
+;;; Commentary:
+;;;
+;;; Python modules which are meant to be used in GUI creation or mainly are
+;;; bindings to low level libraries such as Glue, Mesa, OpenGL, Xorg etc.
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above in alphabetical order.
+;;;