summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMatthias Riße <matrss@0px.xyz>2024-11-30 10:11:10 +0100
committerLars-Dominik Braun <lars@6xq.net>2024-11-30 13:53:12 +0100
commit179e45badae2b9598f64f2e8d392985e783a09bb (patch)
tree4eac8c9f4388f7c9f8eaa57ede000b9d4db53580 /gnu
parent5fd105bf285250af02670b0a9a4615e2b458861d (diff)
gnu: Add ghc-servant-client.
* gnu/packages/haskell-xyz.scm (ghc-servant-client): New variable. Change-Id: I293433a3a5d184a4a015bc16d509e7b5a5ce7991 Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index afbedcba78..ae1aa2d334 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16683,6 +16683,57 @@ serving them . You can learn about the basics in the
CHANGELOG>")
(license license:bsd-3)))
+(define-public ghc-servant-client
+ (package
+ (name "ghc-servant-client")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "servant-client" version))
+ (sha256
+ (base32 "1bdapsr6il0f019ss8wsxndpc8cd5czj40xczay5qhl7fqnxg5pa"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "servant-client")))
+ (inputs (list ghc-servant
+ ghc-servant-client-core
+ ghc-base-compat
+ ghc-http-client
+ ghc-http-media
+ ghc-http-types
+ ghc-kan-extensions
+ ghc-monad-control
+ ghc-semigroupoids
+ ghc-transformers-base
+ ghc-transformers-compat))
+ (native-inputs (list ghc-aeson
+ ghc-http-api-data
+ ghc-sop-core
+ ghc-wai
+ ghc-warp
+ ghc-entropy
+ ghc-hspec
+ ghc-hspec-discover
+ ghc-hunit
+ ghc-network
+ ghc-quickcheck
+ ghc-servant-server
+ ghc-tdigest
+ ghc-markdown-unlit))
+ (arguments
+ `(#:cabal-revision ("6"
+ "0lakjnpvsiai08c5nddgzrnr0a139rr37cyq31hqcbwnsy553l1y")))
+ (home-page "http://docs.servant.dev/")
+ (synopsis "Automatic derivation of querying functions for servant")
+ (description
+ "This library lets you derive automatically Haskell functions that let you query
+each endpoint of a <http://hackage.haskell.org/package/servant servant>
+webservice. . See <http://docs.servant.dev/en/stable/tutorial/Client.html the
+client section of the tutorial>. .
+<https://github.com/haskell-servant/servant/blob/master/servant-client/CHANGELOG.md
+CHANGELOG>.")
+ (license license:bsd-3)))
+
(define-public ghc-servant-client-core
(package
(name "ghc-servant-client-core")