summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:10 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:39 +0200
commit177228ccae5b7184a7550d7490c6009718f50e9c (patch)
treeadc68f7ba4a468efdeed7e6f133699620956c11f /gnu
parent9baa93b8183e41c5c5991d1ff91a479627e8d013 (diff)
gnu: blanket: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation. * gnu/packages/task-management.scm (blanket): Delete trailing #t. [native-inputs]: Remove labels. [inputs]: Add 'bash-minimal'. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I8d3458d16fd4ead7735b3e4b12b8bd0a12459fb0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/task-management.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index f880e7f58a..d472a65174 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -31,6 +31,7 @@
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -334,7 +335,7 @@ a task.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:tests? #f ;the "Validate appstream file" test fails
+ #:tests? #f ;the "Validate appstream file" test fails
#:phases
(modify-phases %standard-phases
(add-after 'wrap 'wrap-libs
@@ -346,20 +347,20 @@ a task.")
(wrap-program (string-append out "/bin/blanket")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
- #t)))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path)))))))))
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("gtk+:bin" ,gtk+ "bin")
- ("pkg-config" ,pkg-config)))
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ `(,gtk+ "bin")
+ pkg-config))
(inputs
(list appstream-glib
+ bash-minimal
gsettings-desktop-schemas
gst-plugins-bad
- gst-plugins-good ;for ScaleTempo plugin
+ gst-plugins-good ;for ScaleTempo plugin
gtk+
libhandy
python