summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-19 14:41:33 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-27 11:25:23 +0200
commit009fb462efcc42585e34b939f800b5f6785f85cf (patch)
treeaad2d74efe168b2d42bad7e231c5fee1de7dfa65 /gnu
parentd3e2b68e380d4e7c514f9f1cdaec60b3013e9c08 (diff)
gnu: Add python-clingox.
* gnu/packages/potassco.scm (python-clingox): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/potassco.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index fe56d1e8b8..9f6b48f890 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -430,6 +430,27 @@ Python code.")))
as a theory to clingo from Python code. It also supports running clingo-dl
directly from the python command line.")))
+(define-public python-clingox
+ (package
+ (name "python-clingox")
+ (version "1.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/python-clingox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ji0sdqlv0byxmdipwk60afsb82r0rr1j73r7j2508hsfk94m2i8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-clingo))
+ (home-page "https://potassco.org/clingo")
+ (synopsis "Auxiliary functions for Clingo")
+ (description "This package provides additional functions to go along with
+the Python bindings for Clingo.")
+ (license license:expat)))
+
(define-public python-asprin
(let ((revision "1")
(commit "bc5a0cf7d9ba346cf91cba66282b5946dbf1331c"))