summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2025-01-01 18:07:45 -0500
committerLeo Famulari <leo@famulari.name>2025-01-07 18:13:45 -0500
commit1dcd0ded86e341cbfd0567cefde1e71684c0cdba (patch)
tree9a71437083273d7866769611838a960063006a48 /gnu/tests
parent92bfa12254e34f097f9448853ce37584fde93006 (diff)
gnu: Add linux-libre-6.12.
* gnu/packages/linux.scm (linux-libre-6.12-version, linux-libre-6.12-gnu-revision, deblob-scripts-6.12, linux-libre-6.12-pristine-source, linux-libre-6.12-source, linux-libre-headers-6.12, linux-libre-6.12): New variables. (linux-libre-headers-latest): Use linux-libre-headers-6.12. (linux-libre-lts-version, linux-libre-lts-gnu-revision, linux-libre-lts-pristine-source, linux-libre-lts-source, linux-libre-lts): Use linux-libre 6.12. * gnu/tests/base.scm (%test-linux-libre-6.12): New test. * gnu/packages/aux-files/linux-libre/6.12-arm.conf, gnu/packages/aux-files/linux-libre/6.12-arm64.conf, gnu/packages/aux-files/linux-libre/6.12-i686.conf, gnu/packages/aux-files/linux-libre/6.12-x86_64.conf, gnu/packages/aux-files/linux-libre/6.12-riscv.conf: New files. * Makefile.am (AUX_FILES): Add them. Change-Id: I430d9dd29cda4bd4b66ad6eddc004935f93bb111
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/base.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/tests/base.scm b/gnu/tests/base.scm
index 02802eb113..d9e30e9b1d 100644
--- a/gnu/tests/base.scm
+++ b/gnu/tests/base.scm
@@ -576,6 +576,9 @@ functionality tests, using the given KERNEL.")
(test-basic-os))
;; Ensure the LTS kernels are up to snuff, too.
+(define %test-linux-libre-6.12
+ (test-basic-os linux-libre-6.12))
+
(define %test-linux-libre-6.6
(test-basic-os linux-libre-6.6))