summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 15:56:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:32 +0000
commitea1de82bce9aeff082aadcffbfdcbd6b9ffd4f3e (patch)
treeed4ce488357dfe412733081d0e668e50d510d415 /gnu/packages
parent92581c8a2e2d7a3e78af96aa99005f86d1a3a750 (diff)
gnu: python-argcomplete: Update to 3.2.2.
* gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/python-xyz.scm (python-argcomplete): Update to 3.2.2. [source]: Delete obsolete patch. [build-system]: Use pyproject-build-system. [arguments]: Override check phase. [native-inputs]: Remove python-flake8; add python-mypy, python-setuptools, and zsh. Change-Id: Ia7e37db2b535177eb2caeeab9d7e075af3f273a3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch29
-rw-r--r--gnu/packages/python-xyz.scm33
2 files changed, 23 insertions, 39 deletions
diff --git a/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch b/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch
deleted file mode 100644
index 98f0ca1473..0000000000
--- a/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Upstream commit fixing testcases for fish>=3.1, see
-https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
-
-diff --git a/test/test.py b/test/test.py
-index e91352b..2c34806 100755
---- a/test/test.py
-+++ b/test/test.py
-@@ -28,6 +28,8 @@
-
- BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
- BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
-+FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
-+FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
-
-
- class TempDir(object):
-@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
- expected_failures = [
- 'test_parse_special_characters',
- 'test_comp_point',
-- 'test_special_characters_double_quoted'
- ]
-+ if FISH_VERSION_TUPLE < (3, 1):
-+ expected_failures.extend([
-+ 'test_special_characters_double_quoted'
-+ ])
-
- skipped = [
- 'test_single_quotes_in_single_quotes',
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a66faf98f..70c42788ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23734,31 +23734,44 @@ JPEG2000 and GIF files in pure Python.")
(define-public python-argcomplete
(package
(name "python-argcomplete")
- (version "1.11.1")
+ (version "3.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "argcomplete" version))
(sha256
(base32
- "0h1przxffrhqvi46k40pzjsvdrq4zc3sl1pc96kkigqppq0vdrss"))
- (patches (search-patches "python-argcomplete-1.11.1-fish31.patch"))))
- (build-system python-build-system)
+ "18h023ma2m2gw8w8dm2pvv4k0vpli94293jl57p2ch4vln79xr7k"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; pip: command not found
+ (substitute* "test/test.py"
+ (("def test_console_script")
+ "def __disable_test_console_script"))
+ (invoke "python3" "./test/test.py" "-v")))))))
(native-inputs
(list python-coverage
- python-flake8
+ python-mypy
python-pexpect
+ python-setuptools
python-wheel
tcsh
fish
- bash)) ;full Bash for 'test_file_completion'
+ bash ;full Bash for 'test_file_completion'
+ zsh))
(home-page "https://github.com/kislyuk/argcomplete")
(synopsis "Shell tab completion for Python argparse")
(description "argcomplete provides extensible command line tab completion
- of arguments and options for Python scripts using @code{argparse}. It's
- particularly useful for programs with many options or sub-parsers that can
- dynamically suggest completions ; for example, when browsing resources over the
- network.")
+of arguments and options for Python scripts using @code{argparse}. It's
+particularly useful for programs with many options or sub-parsers that can
+dynamically suggest completions ; for example, when browsing resources over
+the network.")
(license license:asl2.0)))
(define-public python-csscompressor