summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRick Huijzer <ikbenrickhuyzer@gmail.com>2024-11-08 18:17:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 21:45:45 +0000
commitea195b286e301647208a9cef25251fbfc6c8a983 (patch)
tree4cced4444ad57f494323752be7984aabd02d175a /gnu/packages
parent5f275bbab077faf6b5280d41b60d79e46d42b81d (diff)
gnu: Add python-pyet.
* gnu/packages/python-science.scm (python-pyet): New variable. Change-Id: Ia2be23aeb83911aa93869f82cf0667da8af509c4 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f38992a1c2..ef6d529ffd 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Marco Baggio <marco.baggio@mdc-berlin.de>
;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -896,6 +897,32 @@ density maps, both for interactive and non-interactive use.")
@end itemize")
(license license:expat)))
+(define-public python-pyet
+ (package
+ (name "python-pyet")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyet" version))
+ (sha256
+ (base32 "1dblsx0bv1g453hcx5vwij1zgankwgwvhwllqkn47k578h038xvy"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-mock
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-pandas
+ python-xarray))
+ (home-page "https://github.com/pyet-org/pyet")
+ (synopsis "Python package for evapotranspiration calculation")
+ (description
+ "This package provides a Python library for calculating
+Evapotranspiration using various standard methods.")
+ (license license:expat)))
+
(define-public python-tspex
(package
(name "python-tspex")