summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:15:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:31 +0000
commitd1133823da678fe71df426def511a56866280aaf (patch)
tree494cfd47ba7d05f8e02259e77544706a13221aff /gnu/packages
parent7987f01baa98c946eefd3610bf8cea73679eb0f4 (diff)
gnu: python-myst-parser: Relax some requirements.
* gnu/packages/sphinx.scm (python-myst-parser) [arguments] <#:test-flags>: Disable one more failing test. <#:phases>: Add 'relax-requirements phase. Change-Id: I4f77ce81e9f69b81b18f3faa546c7d8cd77adf50
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 292eaef9d0..4a4332c800 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -924,6 +924,7 @@ and several other projects.")
(define-public python-myst-parser
(package
(name "python-myst-parser")
+ ;; The latest version (v2.0.0) require Sphinx >= v6.
(version "0.18.1")
(source (origin
(method git-fetch) ;for tests
@@ -942,7 +943,17 @@ and several other projects.")
(list #:test-flags #~(list "-k" (string-append
"not test_basic "
"and not test_gettext_html "
- "and not test_fieldlist_extension"))))
+ "and not test_fieldlist_extension "
+ "and not test_syntax_extensions"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; "mdit-py-plugins~=0.3.1"
+ (("0.3.1") "0.4.0")
+ ;; "markdown-it-py>=1.0.0,<3.0.0"
+ (("3.0.0") "4.0.0")))))))
(native-inputs
(list python-beautifulsoup4
python-docutils