summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commitc65098345739ccaccb293a5d7976fecc6b3d7beb (patch)
tree66675739614c3013cfc9836f5ed3c9cd52a8094f /gnu/packages
parente12c377ed15ab99a8830e3437aa560d411ec3202 (diff)
gnu: xsane: Fix cross-compilation.
* gnu/packages/scanner.scm (xsane)[arguments]: Use SEARCH-INPUT-FILE. Change-Id: I4c4423cf1808f5934d97fd20bf25ac074d5617b2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/scanner.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index e3fdf426db..a2faaa2728 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -421,9 +421,9 @@ provided the driver also exposes the buttons.")
(substitute* "src/xsane-save.c"
(("png_ptr->jmpbuf") "png_jmpbuf(png_ptr)"))))
(add-after 'unpack 'use-sane-help-browser
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/xsane.h"
- (("netscape") (which "xdg-open")))))
+ (("netscape") (search-input-file inputs "bin/xdg-open")))))
(add-after 'install 'delete-empty-/sbin
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))