summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 16:00:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:32 +0000
commitb3949c72d9c1962e7dbfeb4c52ca1a71614f62e9 (patch)
tree4628c5e69064ce2e8572299f9064a633720c1423 /gnu/packages
parentea1de82bce9aeff082aadcffbfdcbd6b9ffd4f3e (diff)
gnu: python-traitlets: Update to 5.14.1.
* gnu/packages/python-xyz.scm (python-traitlets): Update to 5.14.1. [arguments]: Disable two typing tests. [native-inputs]: Add python-argcomplete, python-mypy, and python-pytest-mypy-testing. Change-Id: Ie77ca0837977147f657cd4daa2f8f90ed07ebdfd
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 70c42788ec..0c427fe0e3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12510,20 +12510,27 @@ connect strings, then issue SQL commands within IPython or IPython Notebook.")
(define-public python-traitlets
(package
(name "python-traitlets")
- (version "5.9.0")
+ (version "5.14.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "traitlets" version))
(sha256
(base32
- "1ndslgsan1g5xhrvxrv2x03zcfvjb8nzfd90y1m7bkv8khdf5kgn"))))
+ "0zjj8ha4z5lbhhmvcl3q8wp5qmwqq0lwxma3d8qvh10s6xdi11c5"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k" "not mypy_list_typing and not mypy_dict_typing")))
(native-inputs
- (list python-hatchling
+ (list python-argcomplete
+ python-hatchling
+ python-mypy
python-pre-commit
python-pytest
- python-pytest-mock))
+ python-pytest-mock
+ python-pytest-mypy-testing))
(home-page "https://ipython.org")
(synopsis "Configuration system for Python applications")
(description