summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-14 16:31:49 +0800
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:52 +0100
commita6f6f5a993787f35f83e5cda40d3adbddcd891c4 (patch)
treeb490105ceb6549cb864b2a9ddf7d014d75ea5b58 /gnu/packages
parent2b311b24e69bd1cef03e6bbb3cb86b5c53548c7e (diff)
gnu: Remove python-pyodbc-c.
Last updated 7 years ago, doesn't work with current python, with error: undefined symbol: PyUnicode_GetMax * gnu/packages/databases.scm (python-pyodbc-c): Remove variable. Change-Id: If51b6589c33129c7097e3219a4c96cb8d95a0edf
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ea6498211fe..3b3961c5d15 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3609,34 +3609,6 @@ development.")
;; source files are in the public domain.
(license (list license:public-domain license:bsd-3))))
-(define-public python-pyodbc-c
- (package
- (name "python-pyodbc-c")
- (version "3.1.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/daym/pyodbc-c/")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "08y60c5sx0k953zfx0s2a155l8py968sb17ap9a9fg8bjnj783k8"))))
- (build-system python-build-system)
- (inputs
- (list unixodbc))
- (arguments
- `(;; The tests require a running SQL server that they don't help set up.
- #:tests? #f))
- (home-page "https://gitlab.com/daym/pyodbc-c")
- (synopsis "Python ODBC Library written in C")
- (description "@code{python-pyodbc-c} provides a Python DB-API driver
-for ODBC, similar to python-pyodbc but written in C.
-
-It's designed to stand alone and not have other dependencies on other packages
-or languages. It uses only Python's built-in data types.")
- (license (license:x11-style "file://LICENSE.TXT"))))
-
(define-public python-pyodbc
(package
(name "python-pyodbc")