summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:23 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:50 +0000
commit9816aae54342aa2018ce2d827ca14dbb50c62530 (patch)
treec4d2ee350614e0f4e5e5cf681b9fd86b3e5b6211 /gnu/packages
parent13728a610478714c6e4673fa0e4e036c71d8a107 (diff)
gnu: zulip-term: Move to pyproject-build-system.
* gnu/packages/messaging.scm (zulip-term): [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Use it in place of check phase replacement. Change-Id: Ia5be66a35b92d9a9229f450a7724e27167c02eda Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/messaging.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index dd94292f69..e6c13de845 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3236,24 +3236,13 @@ designed for experienced users.")
(base32
"1xhhy3v4wck74a83avil0rnmsi2grrh03cww19n5mv80p2q1cjmf"))
(modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "setup.py"
- (("\\=\\=1\\.7") ">=1.7") ; pytest-mock
- (("\\=\\=2\\.5") ">=2.5") ; pytest-cov
- (("4\\.5\\.2") "4.4.2")) ; lxml
- #t))))
- (build-system python-build-system)
+ (snippet '(substitute* "setup.py"
+ (("\\=\\=1\\.7") ">=1.7") ; pytest-mock
+ (("\\=\\=2\\.5") ">=2.5") ; pytest-cov
+ (("4\\.5\\.2") "4.4.2"))))) ; lxml
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Delete failing tests.
- (delete-file "tests/cli/test_run.py")
- (invoke "pytest"))
- #t)))))
+ '(#:test-flags '("--ignore=tests/cli/test_run.py")))
(inputs
(list python-beautifulsoup4
python-lxml