summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 19:41:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:32 +0000
commit7fe8e4cfc541ccf821f1902be83418b4281f52f0 (patch)
tree45c7c9545e5b9c905f7bef855734c6571a24efd1 /gnu/packages
parentc7a0088d3f9c4a354ce743e90521046540409ecb (diff)
gnu: Add python-rapidfuzz.
* gnu/packages/python-xyz.scm (python-rapidfuzz): New variable. Change-Id: I6ff451a1632f586db45fb7079c2dcef7854d5a5c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fe29ee31e3..b6a6f67089 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2413,6 +2413,28 @@ using distutils2-like setup.cfg files for a package's metadata with a
distribute/setuptools setup.py script.")
(license license:bsd-2)))
+(define-public python-rapidfuzz
+ (package
+ (name "python-rapidfuzz")
+ (version "3.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rapidfuzz" version))
+ (sha256
+ (base32 "1rrx043zqqql31pcp92k61digibymp3l382gaxr4h8717kp0nrim"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-packaging
+ python-pytest
+ python-scikit-build
+ python-setuptools))
+ (home-page "https://github.com/rapidfuzz/RapidFuzz")
+ (synopsis "Rapid fuzzy string matching")
+ (description "RapidFuzz is a fast string matching library for Python and
+C++, which is using the string similarity calculations from FuzzyWuzzy.")
+ (license license:expat)))
+
(define-public python-rawkit
(package
(name "python-rawkit")