summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-12-19 23:03:12 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-24 16:09:50 +0100
commit56045f1ae15fceb8996c699467bdeb22ac8d87f3 (patch)
tree5b78968a712138422dc9691363390d09b504acf3 /gnu/packages
parentea740fef1b320c761668a44eda21b2e95c672b8c (diff)
gnu: Add julia-performancetesttools.
* gnu/packages/julia-xyz.scm (julia-performancetesttools): New variable. Change-Id: Ia3d452f400a8dc0fe78ef8c131101ac2cd46550e Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 1f04558d277..71e5aaa7f48 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4917,6 +4917,31 @@ algorithms, while ensuring that the most efficient implementation is used in
actual computation.")
(license license:expat)))
+(define-public julia-performancetesttools
+ (package
+ (name "julia-performancetesttools")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaTesting/PerformanceTestTools.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v5b8vnnhavra18h0136gahiyl7nc6r3rm3hm359ic3da8yzrnhn"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaTesting/PerformanceTestTools.jl")
+ (synopsis "Enables efficient code generation in test cases")
+ (description
+ "This package enables the Julia compiler to generate
+efficient code when running test cases. Test cases are typically run with
+flags that prevent efficient code generation. This package detects those flags
+and instead spawns a separate Julia process without the flags in which to run
+the test cases.")
+ (license license:expat)))
+
+
(define-public julia-plotthemes
(package
(name "julia-plotthemes")