summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 21:39:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:33 +0000
commit2ee8d8a63d8f76fadc76d9343852a6d4426cd6b7 (patch)
tree586c1b0a639ad5793a071056e5485c832536e81d /gnu/packages
parent33210bced42287ae96b28b51fe22c2e4a2d7afa2 (diff)
gnu: python-readme-renderer: Adjust package style.
* gnu/packages/python-xyz.scm (python-readme-renderer): Fix indentation. [native-inputs]: Add python-setuptools. Change-Id: I47cef84089384d2cf760c166fed9147863d1a415
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 422ba34498..5ead23b687 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32661,25 +32661,25 @@ positioning, and keyboard input.")
(name "python-readme-renderer")
(version "41.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "readme_renderer" version))
- (sha256
- (base32
- "1xvkf2i075rdqkwdrcrw4xglziqd7qs5lb2rbxr5snizi7ji2jsg"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "readme_renderer" version))
+ (sha256
+ (base32
+ "1xvkf2i075rdqkwdrcrw4xglziqd7qs5lb2rbxr5snizi7ji2jsg"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
'(list "-k"
- (string-append
- ;; These tests fail due to slight differences in the generated
- ;; vs expected HTML, e.g. because of difference in whitespace or
- ;; line breaks. (See also
- ;; https://github.com/pypa/readme_renderer/issues/234).
- "not test_md_fixtures[test_CommonMark_008.md]"
- " and not test_rst_fixtures[test_rst_008.rst]"
- " and not GFM"))))
+ (string-append
+ ;; These tests fail due to slight differences in the generated
+ ;; vs expected HTML, e.g. because of difference in whitespace or
+ ;; line breaks. (See also
+ ;; https://github.com/pypa/readme_renderer/issues/234).
+ "not test_md_fixtures[test_CommonMark_008.md]"
+ " and not test_rst_fixtures[test_rst_008.rst]"
+ " and not GFM"))))
(propagated-inputs
(list python-bleach
python-docutils
@@ -32688,14 +32688,15 @@ positioning, and keyboard input.")
python-cmarkgfm)) ;required by postorius
(native-inputs
(list python-pytest
+ python-setuptools
python-wheel))
(home-page "https://github.com/pypa/readme_renderer")
(synopsis "Render README files in Warehouse")
(description
"Readme Renderer is a library that will safely render arbitrary README
files into HTML. It is designed to be used in Warehouse to render the
-@code{long_description} for packages. It can handle Markdown, reStructuredText,
-and plain text.")
+@code{long_description} for packages. It can handle Markdown,
+reStructuredText, and plain text.")
(license license:asl2.0)))
(define-public python-lazr-delegates