summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2025-01-02 10:09:30 -0600
committerjgart <jgart@dismail.de>2025-01-02 10:20:39 -0600
commit183f330905e8da0575353628ffd51fcdbb46844f (patch)
treef6f0d1790cc1bb919bb20c86c362a771d2337225 /gnu/packages
parent8c11f8740a52339f51fe1841658e8e549589f2e2 (diff)
gnu: Add python-lsp-black.
* gnu/packages/python-xyz.scm (python-lsp-black): New variable. Co-authored-by: jgart <jgart@dismail.de> Change-Id: I9f5e1b8b77e530fed38e6621ac214605bc377724
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8641144a46..a922ebbb30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3321,6 +3321,30 @@ approximate nearest neighbor search with Python bindings.")
Unicode-to-LaTeX conversion.")
(license license:expat)))
+(define-public python-lsp-black
+ (package
+ (name "python-lsp-black")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-lsp/python-lsp-black")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gwf3vwb01a3l8b75jbn8kyfmn0lva8vpgjnr75vazhm3lsf78fp"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-black python-lsp-server python-tomli))
+ (native-inputs
+ (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/python-lsp/python-lsp-black")
+ (synopsis "Black plugin for the Python LSP Server")
+ (description "This package provides a plugin with support for the
+@code{python-black} formatter for the Python LSP Server.")
+ (license license:expat)))
+
(define-public python-pylsp-mypy
(package
(name "python-pylsp-mypy")