summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 13:08:46 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:37 +0000
commit16ae869fef69d89eafe3e156f7aa6fed9776f5d6 (patch)
tree1bc985bc4f32cdcf9b0f4ff72339caeba4083f3e /gnu/packages
parente3222a53022b01fbba12708133f3b8bcb4dacf52 (diff)
gnu: Add python-jsonschema-specifications.
* gnu/packages/python-xyz.scm (python-jsonschema-specifications): New variable. Change-Id: If1f7fa0d4e0bc505d9378ce892af298365754daf
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 637faed3b3..e5dbe28264 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6007,6 +6007,39 @@ and convert DDL to BigQuery JSON schema.")
(lambda _
(setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))))
+(define-public python-jsonschema-specifications
+ (package
+ (name "python-jsonschema-specifications")
+ (version "2023.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonschema_specifications" version))
+ (sha256
+ (base32 "1k348xkq45jx13kmv32ls6k4qvjq3ywd4q0i7zamw3z7nf3ng9s8"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; The build system does not like this.
+ (substitute* "pyproject.toml"
+ ((" \"Topic :: File Formats.*") "")))))))
+ (propagated-inputs (list python-importlib-resources
+ python-referencing-bootstrap))
+ (native-inputs
+ (list python-hatchling python-hatch-vcs python-pytest))
+ (home-page "https://github.com/python-jsonschema/jsonschema-specifications")
+ (synopsis
+ "JSON Schema meta-schemas and vocabularies, exposed as a Registry")
+ (description
+ "This package provides JSON support files from the JSON Schema
+Specifications (metaschemas, vocabularies, etc.), packaged for runtime access
+from Python as a referencing-based Schema Registry.")
+ (license license:expat)))
+
(define-public python-schema
(package
(name "python-schema")