summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars Bilke <lars.bilke@ufz.de>2024-11-19 15:18:06 +0100
committerLudovic Courtès <ludo@gnu.org>2024-11-29 15:45:19 +0100
commitf129a6cc591817c5c51770d5b8712eeb344ba4e4 (patch)
tree999093fde7485a58ebc92ad184631714019c1832 /gnu/packages
parent7ec33a1cc36492d11207833a0ce4c46c9d232845 (diff)
gnu: petsc: Remove store references on make and gcc.
Reduces closure size from 970 MB to around 700 MB for petsc-openmpi package and also makes `guix pack` packages containing petsc bit-reproducible (by removing make it removes implicit guile dependency). * gnu/packages/maths.scm (petsc)[arguments]: Add patterns in ’clean-local-references’ and ‘clear-reference-to-compiler’. Change-Id: I465c325b152b09befdb746e5bc47fbeaf9a061dc Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b8575397f4..dd5c00c61a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3422,7 +3422,8 @@ September 2004}")
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
(("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+-arch[0-9]+-[0-9]+")
- "Machine characteristics: Linux-x.x.x-archx-x"))
+ "Machine characteristics: Linux-x.x.x-archx-x")
+ (("([[:graph:]]+)/bin/make") "\"make"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [[:digit:]]+") "MAKE_NP = 2")
@@ -3462,7 +3463,8 @@ September 2004}")
(("([[:graph:]]+)/bin/make") "make")
(("([[:graph:]]+)/bin/diff") "diff")
(("([[:graph:]]+)/bin/sed") "sed")
- (("([[:graph:]]+)/bin/gfortran") "gfortran")))))
+ (("([[:graph:]]+)/bin/gfortran") "gfortran")
+ (("([[:graph:]]+)/bin/gcov") "gcov")))))
;; Some of the tests get linked with '-L$prefix/lib -lpetsc' (even
;; though that's unnecessary because they also explicitly link