summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-09-30 14:33:38 +0200
committerAndreas Enge <andreas@enge.fr>2025-01-16 11:24:07 +0100
commitea7c240bd37fcb67a1f794e10db9a7ec02874578 (patch)
tree480f8f9ad60aa3c70226ba7faf5f8f1c78aa3452 /gnu/packages
parentfa13f86235c86ebcacf60df9ad76b2ff532caefd (diff)
gnu: pari-gp: Update to 2.17.0.
* gnu/packages/algebra.scm (pari-gp): Update to 2.17.0. * gnu/packages/patches/pari-gp-qfcvp.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: If0ea83651ae7aa4cb5de61dfaa5ec2b11051eaab
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/algebra.scm4
-rw-r--r--gnu/packages/patches/pari-gp-qfcvp.patch19
2 files changed, 21 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5da77b6318..f71fd46c33 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -242,7 +242,7 @@ the real span of the lattice.")
(define-public pari-gp
(package
(name "pari-gp")
- (version "2.15.5")
+ (version "2.17.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -250,7 +250,7 @@ the real span of the lattice.")
version ".tar.gz"))
(sha256
(base32
- "10grsn8wr8k02akj8f8wm1rhzrk0qls4phr46gv59nfr2msxmz8f"))))
+ "1a5fn64x7255ma7rkkjg5g17fq6mnjlzjfi8wbncc24dy77ff8z7"))))
(build-system gnu-build-system)
(native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
diff --git a/gnu/packages/patches/pari-gp-qfcvp.patch b/gnu/packages/patches/pari-gp-qfcvp.patch
new file mode 100644
index 0000000000..4dfaedc54a
--- /dev/null
+++ b/gnu/packages/patches/pari-gp-qfcvp.patch
@@ -0,0 +1,19 @@
+commit 9086c5ce165bdff6ac0e63b641279f6d9e44f4a7
+Author: Bill Allombert <Bill.Allombert@math.u-bordeaux.fr>
+Date: Tue Oct 1 23:54:34 2024 +0200
+
+ qfcvp: fix prototype code [#2575]
+
+diff --git a/src/functions/linear_algebra/qfcvp b/src/functions/linear_algebra/qfcvp
+index 5ee883390a..7be5fa9570 100644
+--- a/src/functions/linear_algebra/qfcvp
++++ b/src/functions/linear_algebra/qfcvp
+@@ -1,7 +1,7 @@
+ Function: qfcvp
+ Section: linear_algebra
+ C-Name: qfcvp0
+-Prototype: GGDGDGD0,L,p
++Prototype: GGDGDGD0,L,
+ Help: qfcvp(x,t,{B},{m},{flag=0}): x being a square and symmetric
+ matrix representing a positive definite quadratic form, and t a vector of
+ the same dimension, this function deals with the vectors of whose squared