summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2025-01-16 11:50:04 -0600
committerjgart <jgart@dismail.de>2025-01-16 11:53:37 -0600
commitda69a9e15115d6acc7e4a95cc6295f97c97f827e (patch)
treed10035572eaccee97c2d45bff8ac166d0d2bd14e /gnu/packages
parent7aae0e2c159b1612b405a372b18f25fbb58f9d82 (diff)
gnu: Add python-pathspec.
* gnu/packages/python-xyz.scm (python-pathspec): New variable. Change-Id: I8576103866117aa46ef3d5fc7274926b8a4878d9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 153c869e25..62af6ad2b1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38033,6 +38033,24 @@ Python iterables (lists, tuples, dicts).")
and setting the color of terminal output, via HyDEV.")
(license license:expat)))
+(define-public python-pathspec
+ (package
+ (name "python-pathspec")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathspec" version))
+ (sha256
+ (base32 "04jpkzic8f58z6paq7f3f7fdnlv9l89khv3sqsqk7ax10caxb0m4"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core python-setuptools))
+ (home-page "https://github.com/cpburnz/python-pathspec")
+ (synopsis "Gitignore style pattern matching of file paths")
+ (description
+ "Utility library for gitignore style pattern matching of file paths.")
+ (license license:mpl2.0)))
+
(define-public python-mike
(package
(name "python-mike")