summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-17 11:31:56 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2025-01-16 00:16:39 +0300
commitd568c9295110c138bfb8641d971d308d7e8be0c5 (patch)
treeb57b2823487ced680aa112688bc1b5a58bc44db4 /gnu/packages
parent0ba2136df7f7a574e88d07fb0be176322ace94ed (diff)
gnu: sslh: Use GEXPs.
* gnu/packages/networking.scm (sslh): Use GEXPs. Change-Id: I5b31afdfeb1f1f9b2e5f86290adc405f3a90a367
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm61
1 files changed, 29 insertions, 32 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8ab4378ba8..295c2421ec 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2740,38 +2740,35 @@ library remains flexible, portable, and easily embeddable.")
(inputs
(list libev libconfig pcre))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* "t"
- ;; XXX: Disable a failing test.
- (("my \\$DROP_CNX = 1;")
- "my $DROP_CNX = 0;")
- ;; XXX: "sslh-select" seems to not support this option for some
- ;; reason. According to "sslhconf.cfg" this option just overrides the
- ;; verbosity configuration so it seems that we can safely drop it.
- (("-v 4")
- ""))
- (substitute* "test.cfg"
- ;; The Guix build environment lacks ‘ip4-localhost’.
- (("ip4-localhost") "localhost"))
- #t))
- ;; Many of these files are mentioned in the man page. Install them.
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/sslh")))
- (install-file "README.md" doc)
- (for-each
- (lambda (file)
- (install-file file (string-append doc "/examples")))
- (append (find-files "." "\\.cfg")
- (find-files "scripts"))))
- #t)))
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "USELIBCONFIG=1"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-tests
+ (lambda _
+ (substitute* "t"
+ ;; XXX: Disable a failing test.
+ (("my \\$DROP_CNX = 1;")
+ "my $DROP_CNX = 0;")
+ ;; XXX: "sslh-select" seems to not support this option for some
+ ;; reason. According to "sslhconf.cfg" this option just overrides the
+ ;; verbosity configuration so it seems that we can safely drop it.
+ (("-v 4")
+ ""))
+ (substitute* "test.cfg"
+ ;; The Guix build environment lacks ‘ip4-localhost’.
+ (("ip4-localhost") "localhost"))))
+ ;; Many of these files are mentioned in the man page. Install them.
+ (add-after 'install 'install-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/sslh")))
+ (install-file "README.md" doc)
+ (for-each
+ (lambda (file)
+ (install-file file (string-append doc "/examples")))
+ (append (find-files "." "\\.cfg")
+ (find-files "scripts")))))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "USELIBCONFIG=1"
+ (string-append "PREFIX=" #$output))
#:test-target "test"))
(home-page "https://www.rutschle.net/tech/sslh/README.html")
(synopsis "Applicative network protocol demultiplexer")