summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:45 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:23 +0200
commitcf468ebd38d2f639a922da720f49e58f914f356e (patch)
tree66983ec19990d3febb6d0528699b2ab79987433e /gnu/packages
parente5bf0cfa97f524f73c20e3be9a5470b2e2ce3754 (diff)
gnu: nnpack: Depend on python-peachpy only for x86_64.
* gnu/packages/machine-learning.scm (nnpack)[native-inputs]: Provide python-peachpy only when 'target-x86-64?'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 9363b01e71..137f764e9c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4045,7 +4045,9 @@ and Darknet.")
pthreadpool
googletest))
(native-inputs
- (list python python-peachpy python-six))
+ `(,python
+ ,@(if (target-x86-64?) (list python-peachpy) '())
+ ,python-six))
;; Supported for Linux.
(supported-systems '("x86_64-linux" "armhf-linux" "aarch64-linux"))
(license license:bsd-2))))