summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJonathan Pieper <jpieper@mailbox.org>2024-04-15 19:45:04 +0200
committerjgart <jgart@dismail.de>2024-10-11 11:21:36 -0500
commitc278109a89cbf2df1b22cdcd98a8d24289d0f621 (patch)
tree2b02b03d5b2cba7811b24fa0d857f206b85c3bca /gnu/packages
parent00dc16da54d30815fa96709da7dcd24d0cf53d49 (diff)
gnu: Add python-docstring-to-markdown.
* gnu/packages/python-xyz.scm (python-docstring-to-markdown): New variable. Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7eb2498a99b..19ba2fa9813 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1528,6 +1528,25 @@ template")
variables into the markdown template")
(license license:expat)))
+(define-public python-docstring-to-markdown
+ (package
+ (name "python-docstring-to-markdown")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "docstring-to-markdown" version))
+ (sha256
+ (base32 "0gdpabnyl1kyy0cjrnph6xl4fyhgim50a1amsaqq3hahki6i2ip1"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-lsp/docstring-to-markdown")
+ (synopsis "On the fly conversion of Python docstrings to markdown")
+ (description
+ "This module can convert Python docstrings to Markdown.
+It can recognise reStructuredText inside docstrings and convert multiple of its
+features to Markdown. It also includes initial support for Google-formatted docstrings.")
+ (license license:lgpl2.1+)))
+
(define-public python-mysql-connector-python
(package
(name "python-mysql-connector-python")