summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-15 14:38:10 +0800
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:58 +0100
commitba2e538ce352c033722734737be4793e01851892 (patch)
treefad05894651f4f940685d1b4bb85bf40dac79b9a /gnu/packages
parent2260a70870d82672fd2285a2554be2b2a6f358d5 (diff)
gnu: python-flask-misaka: Update to 1.0.1.
* gnu/packages/python-web.scm (python-flask-misaka): Update to 1.0.1. [build-system]: Switch to pyproject-build-system. [native-inputs]: Add python-flask, python-pytest, python-setuptools and python-wheel. Remove python-coverage and python-mock. [propagated-inputs]: Add python-markupsafe. Remove python-flask. Change-Id: Ib737e6268f98227909606753ffe8d9f72c539f73
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index edac2e77fc2..68d5128a6ed 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2349,19 +2349,21 @@ into Jinja2 by default.")
(define-public python-flask-misaka
(package
(name "python-flask-misaka")
- (version "1.0.0")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-Misaka" version))
(sha256
(base32
- "12gm6hq3lvlj0ddw8p6lk5pky8jk3pw758ihffjl49shnnzc68zl"))))
- (build-system python-build-system)
+ "1yi9iall3ml1n8bff1mg49xajmldcm5pc0fkpl3w2rlnny08giax"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags #~(list "tests.py")))
(native-inputs
- (list python-coverage python-mock))
+ (list python-flask python-pytest python-setuptools python-wheel))
(propagated-inputs
- (list python-flask python-misaka))
+ (list python-markupsafe python-misaka))
(home-page "https://github.com/singingwolfboy/flask-misaka/")
(synopsis "Flask interface to Misaka, a Markdown parsing library")
(description