summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 12:30:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:50 +0100
commit869457aadf48251d17f2b6644c0cc153e184a3eb (patch)
tree99fcf404c33e29b5c8806e10a813c618c4bd8821 /gnu/packages
parent6aa588ed8693706db62e9d412f0d8dda490aeee0 (diff)
gnu: go-gopkg-in-square-go-jose-v2: Disable tests.
* gnu/packages/golang-web.scm (go-gopkg-in-square-go-jose-v2): Disable tests. Change-Id: I8bfc5c1a37077b6dc63030202341112cd66dd74b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index bc8c23b243d..59453dfe44f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3145,6 +3145,8 @@ programming language.")
programming language, which supports draft-04, draft-06 and draft-07.")
(license license:asl2.0))))
+;; XXX: This repository has been archived by the owner on Feb 27, 2023. It is
+;; now read-only and it is DEPRECATED.
(define-public go-gopkg-in-square-go-jose-v2
(package
(name "go-gopkg-in-square-go-jose-v2")
@@ -3160,7 +3162,12 @@ programming language, which supports draft-04, draft-06 and draft-07.")
(base32 "1b1nhqxfmhzwrfk7pkvp2w3z3d0pf5ir00vizmy2d4xdbnldn70r"))))
(build-system go-build-system)
(arguments
- (list #:import-path "gopkg.in/square/go-jose.v2"))
+ (list
+ ;; XXX: We strongly encourage users of square/go-jose to migrate to v3
+ ;; of go-jose/go-jose. No support, security fixes or updates will be
+ ;; delivered to the v1/v2 branches in the Square repository.
+ #:tests? #f
+ #:import-path "gopkg.in/square/go-jose.v2"))
(propagated-inputs
(list go-golang-org-x-crypto))
(native-inputs