summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-01-15 22:30:18 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-15 22:31:45 +0100
commit6f74832d45b4b86208606af8c23868687f863a28 (patch)
tree27bedfc972cb787d960e6aaef02c71012171bd85 /gnu/packages
parentd568c9295110c138bfb8641d971d308d7e8be0c5 (diff)
gnu: Add emacs-org-sticky-header.
* gnu/packages/emacs-xyz.scm (emacs-org-sticky-header): New variable. Change-Id: I0f1f87efb9617c91281424967f52be77e83dc993
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce131bf7fd..9b3139dfa1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23874,6 +23874,24 @@ presentations by progressively revealing individual subtrees of the
document.")
(license license:gpl3+))))
+(define-public emacs-org-sticky-header
+ (package
+ (name "emacs-org-sticky-header")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alphapapa/org-sticky-header/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lr7khrs3d4229h5mmxbwc2jp192m2b9gfl85s3bhzbp6jpjf17y"))))
+ (build-system emacs-build-system)
+ (synopsis "Always show current org header line")
+ (description "This package provides the ability to always show the current
+org header line at the top of the window--no matter how far down you scrolled.")
+ (home-page "https://github.com/alphapapa/org-sticky-header")
+ (license license:gpl3+)))
+
(define-public emacs-scratch-el
(package
(name "emacs-scratch-el")