summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorhiecaq <this@hiecaq.org>2024-11-28 23:13:59 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-16 13:32:49 +0800
commit43e391d76c91195f8b6e59f9c7045bb5f8a2ecf5 (patch)
tree8e06a57f5e6a9d977c8edbd2d33e573c749ff4ea /gnu/packages
parent6d0bb872505cbca809327a6dd59cfcf4c23a77f9 (diff)
gnu: ghc-xmobar: Update to 0.48.1.
* gnu/packages/wm.scm (ghc-xmobar): Update to 0.48.1. [inputs]: Add ghc-extra. [home-page]: Point to the actual project home-page. Change-Id: I4a43c774a00853eb15a0874d5228729867d0606e Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5631c0a834..cc5da92eef 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1082,13 +1082,13 @@ tiled on several screens.")
(define-public ghc-xmobar
(package
(name "ghc-xmobar")
- (version "0.46")
+ (version "0.48.1")
(source (origin
(method url-fetch)
(uri (hackage-uri "xmobar" version))
(sha256
(base32
- "0glpiq7c0qwfcxnc2flgzj7afm5m1a9ghzwwcq7f8q27m21kddrd"))))
+ "1infcisv7l00a4z4byjwjisg4yndk0cymibfii1c7yzyzrlvavhl"))))
(build-system haskell-build-system)
(properties '((upstream-name . "xmobar")))
(native-inputs
@@ -1097,6 +1097,7 @@ tiled on several screens.")
(list ghc-alsa-core
ghc-alsa-mixer
ghc-dbus
+ ghc-extra
ghc-hinotify
ghc-http-client-tls
ghc-http-conduit
@@ -1130,7 +1131,7 @@ tiled on several screens.")
(lambda _
(substitute* "src/Xmobar/X11/CairoSurface.hsc"
(("cairo/cairo-xlib.h") "cairo-xlib.h")))))))
- (home-page "https://xmobar.org")
+ (home-page "https://codeberg.org/xmobar/xmobar")
(synopsis "Haskell library for minimalistic text based status bars")
(description
"@code{ghc-xmobar} is the haskell library that @code{xmobar} is based on.