summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMatthias Riße <matrss@0px.xyz>2024-11-30 10:10:10 +0100
committerLars-Dominik Braun <lars@6xq.net>2024-11-30 13:53:12 +0100
commit0fe87722697fd83527e1e8c134d13ac8e44246fb (patch)
tree9fe7c7fc5f395bcdba65da6591998700a9d9efb9 /gnu/packages
parent4a2c74b951c473772f5422d4fa7a68b0ff7ed75e (diff)
gnu: Add ghc-tdigest.
* gnu/packages/haskell-xyz.scm (ghc-tdigest): New variable. Change-Id: If4fdd492a103de94c30eab6f1399d77bee7ddc1a Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9c3b990275..30a674b080 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -17051,6 +17051,34 @@ such as ala'.")
"Lighweight pure data validation based on Applicative and Selective functors.")
(license license:mpl2.0)))
+(define-public ghc-tdigest
+ (package
+ (name "ghc-tdigest")
+ (version "0.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tdigest" version))
+ (sha256
+ (base32 "1dvkf7cs8dcr13wza5iyq2qgvz75r33mzgfmhdihw62xzxsqb6d3"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "tdigest")))
+ (inputs (list ghc-base-compat ghc-reducers ghc-semigroupoids ghc-vector
+ ghc-vector-algorithms))
+ (native-inputs (list ghc-semigroups ghc-tasty ghc-tasty-quickcheck))
+ (arguments
+ `(#:cabal-revision ("3"
+ "0a39vwf37hkh06rn79blr3bw7ij05pgpxrkc9cldgdd5p4gvn1qn")))
+ (home-page "https://github.com/phadej/haskell-tdigest#readme")
+ (synopsis "On-line accumulation of rank-based statistics")
+ (description
+ "This package provides a new data structure for accurate on-line accumulation of
+rank-based statistics such as quantiles and trimmed means. . See original
+paper: \"Computing extremely accurate quantiles using t-digest\" by Ted Dunning
+and Otmar Ertl for more details
+<https://github.com/tdunning/t-digest/blob/07b8f2ca2be8d0a9f04df2feadad5ddc1bb73c88/docs/t-digest-paper/histo.pdf>.")
+ (license license:bsd-3)))
+
(define-public ghc-tomland
(package
(name "ghc-tomland")