summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 15:24:51 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:43 +0000
commit0b13b4377d5539354604f1c390fa1a599bc892ed (patch)
tree0736502ff0059bb27f4fe2ffb642678a88013ad4 /gnu/packages
parent1114224fd8af833c8ca64687575b3692565c3653 (diff)
gnu: python-aplpy: Update to 2.2.0.
* gnu/packages/astronomy.scm (python-aplpy): Update to 2.2.0. [arguments]<tests>: Enable them. <phases>: Add 'set-env phase. [native-inputs]: Add python-setuptools, python-setuptools-scm, and python-wheel. Change-Id: I050d5e174112afe5abd707e784a152feac5cef59
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6787278f64..b56b340eeb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1532,21 +1532,28 @@ model-fitting photometry or morphological analyses.")
(define-public python-aplpy
(package
(name "python-aplpy")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aplpy" version))
(sha256
- (base32 "0ph9jhv4q4i4z6nkqr6hjw9148kdlnayxsn83qgv5dqn0h3nc9r8"))))
+ (base32 "03c8k7y75f5bwm8d08fr5xfaay4d9jzr5sas4j2frs7zrr8aak51"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; FIXME: https://github.com/aplpy/aplpy/issues/492
- #:tests? #f
+ #:test-flags #~(list "--pyargs" "aplpy")
#:phases
#~(modify-phases %standard-phases
- (delete 'sanity-check))))
+ (add-after 'unpack 'set-env
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ (list python-pytest-astropy
+ python-pytest-mpl
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-astropy
python-matplotlib
@@ -1557,9 +1564,6 @@ model-fitting photometry or morphological analyses.")
python-reproject
python-scikit-image
python-shapely))
- (native-inputs
- (list python-pytest-astropy
- python-pytest-mpl))
(home-page "http://aplpy.github.io")
(synopsis "Astronomical Plotting Library in Python")
(description