summaryrefslogtreecommitdiff
path: root/gnu/packages/zig-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-20 08:36:13 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-31 18:50:45 +0800
commita1c903df5368792194b8b20b26a41bb186b174e3 (patch)
treeb60f9b891e90674393d5d2b3fd5fc941cee4981b /gnu/packages/zig-xyz.scm
parentc66584933f4c9051eb4c10deae96cf25c65198ab (diff)
gnu: Add zig-xkbcommon.
* gnu/packages/zig-xyz.scm (zig-xkbcommon): New variable. Change-Id: I1e63493f67e3aef1b52b8faa4aaf30a0a16b03ba
Diffstat (limited to 'gnu/packages/zig-xyz.scm')
-rw-r--r--gnu/packages/zig-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 09587aec46..2cb877790b 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -159,6 +159,27 @@ interface.")
(home-page "https://codeberg.org/ifreund/zig-wayland")
(license license:expat)))
+(define-public zig-xkbcommon
+ (package
+ (name "zig-xkbcommon")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ifreund/zig-xkbcommon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16f59n7l2gcpnq8gb4v8skr4jhb2l6ax75rna92nqzj15f4ikqag"))))
+ (build-system zig-build-system)
+ (arguments (list #:skip-build? #t))
+ (propagated-inputs (list libxkbcommon))
+ (synopsis "Zig bindings for libxkbcommon")
+ (description "This package provides Zig bindings for @code{libxkbcommon}.")
+ (home-page "https://codeberg.org/ifreund/zig-xkbcommon")
+ (license license:expat)))
+
(define-public zig-zls
(package
(name "zig-zls")