summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorJosep Bigorra <jjbigorra@gmail.com>2024-11-27 22:30:54 +0100
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-01 19:04:50 +0800
commitd08c219b4abf56d4b94f01827cc7dab6de3eae5f (patch)
tree70dfaa6333d0b0a55ea08aa07e12fb7a351b8a2f /gnu/packages/wm.scm
parentaf13915b28c1ce72c843e6df711a64305db05296 (diff)
gnu: Add scenefx.
* gnu/packages/wm.scm (scenefx): New variable. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Change-Id: Ia91747cbec59226a83a020b5fedbfd99886c35df
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 921f975037..2ab6f88cd5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3969,3 +3970,32 @@ battery efficient---polling is only done when absolutely necessary.")
configuration files of Wayifre. It can set key and mouse bindings,
configure input, and customize Wayfire plugins.")
(license license:expat)))
+
+(define-public scenefx
+ (package
+ (name "scenefx")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wlrfx/scenefx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r7f8bprsn0mwlkmc8d14nr3iibljfyxypb4i06v66ghlngaw6dw"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config
+ ;; for wayland-scanner.
+ wayland))
+ (inputs (list pixman
+ mesa
+ libxkbcommon
+ libdrm
+ wlroots-0.17))
+ (home-page "https://github.com/wlrfx/scenefx")
+ (synopsis "Drop-in replacement for the wlroots scene API")
+ (description
+ "A drop-in replacement for the wlroots scene API that allows wayland
+compositors to render surfaces with eye-candy effects.")
+ (license license:expat)))