summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-10-15 21:38:25 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-30 00:51:57 +0100
commiteadd7180973e67fb5b41f34b47e7ade294b09b65 (patch)
tree5c0faf5cd69d13f81e7fa83146e46e38a8f0bbb7 /gnu/packages/web.scm
parent7e8acd980d47f82025c79ee080ec7d1d23079cc4 (diff)
gnu: nginx: Update to 1.27.2.
* gnu/packages/web.scm (nginx): Update to 1.27.2. (nginx-documentation): Update to 1.27.2. Change-Id: I082a410630f1ea9c6765233e159b04134758354d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 825dedfed2..8f816acfd9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -529,14 +529,14 @@ the same, being completely separated from the Internet.")
;; Track the ‘mainline’ branch. Upstream considers it more reliable than
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
- (version "1.27.1")
+ (version "1.27.2")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "1z5x0i0k1hmnxm7mb3dfn6qrz9am96my5ivinxl3gsp1dj5acyxx"))))
+ "1yi53dd6babjg3xx1jl19d0y0xkdi2yjg9pw790w38mkl31wy7m9"))))
(build-system gnu-build-system)
(inputs (list libxcrypt libxml2 libxslt openssl pcre zlib))
(arguments
@@ -627,9 +627,9 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.27.1")
- (revision 3114)
- (changeset "051789a80bcb"))
+ (let ((version "1.27.2")
+ (revision 3130)
+ (changeset "cee30b2e0ae2"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -641,7 +641,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(file-name (string-append name "-" version))
(sha256
(base32
- "0p198cjnhypssmj4mrj6wx2lbrfgw84i2fa4ydzdbjgkdzp803mv"))))
+ "1d8rkhry7y2mm6gfq8xzqwyivy2zyl1d96wcx4q5r58mhj8pk2c6"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite