summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:49:09 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:41 +0300
commitaa40c94446c4ddc52cf9d7e3a440695707f6f534 (patch)
tree8533cc04b50cbc73d590250bd045a3a0fc33f8fe /gnu/packages/web.scm
parent25a33a64b9a3b020b5671a06686c6caee30aac95 (diff)
gnu: Add go-jqp.
* gnu/packages/golang-xyz.scm (go-jqp): New variable. Change-Id: I736e039a456960e0e5864d7d197b2a6a823bbe58 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index cfebf7785a..b10c03a7f4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5631,6 +5631,45 @@ processor.")
#:unpack-path "github.com/itchyny/gojq"
#:install-source? #f)))))
+(define-public go-jqp
+ (package
+ (name "go-jqp")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/noahgorstein/jqp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11xqh4113gkzp32hd4dg4cvjp40q3hxfh3889wd4bw2snl0alvcb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.22
+ #:embed-files #~(list ".*.xml")
+ #:install-source? #f
+ #:import-path "github.com/noahgorstein/jqp"))
+ (inputs
+ (list go-github-com-spf13-viper
+ go-github-com-spf13-cobra
+ go-github-com-muesli-termenv
+ go-github-com-itchyny-gojq
+ go-github-com-itchyny-timefmt-go
+ go-github-com-charmbracelet-lipgloss
+ go-github-com-charmbracelet-bubbletea
+ go-github-com-charmbracelet-bubbles
+ go-github-com-atotto-clipboard
+ go-github-com-alecthomas-chroma-v2))
+ (home-page "https://github.com/noahgorstein/jqp")
+ (synopsis "TUI playground to experiment with jq")
+ (description
+ "This package provides an interactive TUI to explor the @code{jq} command
+line utility. The command accepts an optional query argument which will be
+executed against the input JSON or newline-delimited JSON (NDJSON).")
+ (license license:expat)))
+
(define-public pup
(let ((revision "1")
(commit "681d7bb639334bf485476f5872c5bdab10931f9a"))