summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/time.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index cb89d04bf52..c2d45239eaa 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -159,7 +159,11 @@ expressions.")
(call-with-output-file "src/tzdata/zoneinfo/__init__.py"
(const #t)))))))
(inputs (list tzdata))
- (native-inputs (list python-pytest python-pytest-subtests))
+ (native-inputs
+ (list python-pytest
+ python-pytest-subtests
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/python/tzdata")
(synopsis "Python wrapper of IANA time zone data")
(description "This package provides a thin Python wrapper around tzdata.")