summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-22 15:27:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-22 15:28:25 +0100
commit18a25a69baa1c735dd0d7747aa3a70f7af7b328f (patch)
tree9dc0d7592314430e5b4b20a4f12595373096cd98 /gnu/packages/sphinx.scm
parentf8e9462982341d6a67af79b5d99e3163a8b11ce1 (diff)
gnu: python-sphinx-click: Update to 6.0.0.
* gnu/packages/sphinx.scm (python-sphinx-click): Update to 6.0.0. [arguments]: Add phase 'fix-build-system; remove custom 'check phase. [native-inputs]: Remove python-pbr; add python-setuptools. Change-Id: I0796ee373f9172686753d5d32d274917828d3b41
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 87b0251b471..13a1701e0aa 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -348,22 +348,25 @@ Apple help books.")
(define-public python-sphinx-click
(package
(name "python-sphinx-click")
- (version "4.0.3")
+ (version "6.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sphinx-click" version))
(sha256
(base32
- "1nqy3b7wr64rbmdp7kpi723az53a89y6250h46i505g1rw0czam1"))))
- (build-system python-build-system)
+ "0ns6mfiw4q6g0kh11dfyzpn0rkjq9v4f3w8ry0pn5in03lr69mpm"))))
+ (build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests")))))))
- (native-inputs (list python-pbr python-pytest python-wheel))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-system
+ (lambda _
+ ;; The build system is confused about this top level directory,
+ ;; so we delete it.
+ (delete-file-recursively "releasenotes"))))))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(propagated-inputs (list python-click python-docutils python-sphinx))
(home-page "https://github.com/click-contrib/sphinx-click")
(synopsis "Sphinx extension that documents click applications")