summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 21:26:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:44 +0200
commitcabafd38b4914ff1d24eb5f25aa69c9faa8a52df (patch)
tree666687f341565b9fd87a2f66bad05b982606ed79 /gnu/packages/sequoia.scm
parente38a3a35d4aeac11b8347dfc0e8ff56ccb8124c2 (diff)
gnu: Add rust-sequoia-keystore-0.6.
* gnu/packages/sequoia.scm (rust-sequoia-keystore-0.6): New variable. (rust-sequoia-keystore-0.2): Remove variable. Change-Id: I8ec2457bebef04f8498c1b5e87e98e852539e77f
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 35279743b16..a9b872830b0 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -187,22 +187,23 @@ than just headers; it requires tight integration with the MUA.")
"This package provides interprocess communication infrastructure for Sequoia.")
(license license:lgpl2.0+)))
-(define-public rust-sequoia-keystore-0.2
+(define-public rust-sequoia-keystore-0.6
(package
(name "rust-sequoia-keystore")
- (version "0.2.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "sequoia-keystore" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "11rb2k5v2mc5nf2bafp78nydgcx4gizyxqa9b9lc3d1b73mqv2ad"))))
+ (base32 "168scr1nv5h1fm67p1p59ym267db07kg3fw3shrramaq0af2smx8"))))
(build-system cargo-build-system)
(arguments
`(#:features '("sequoia-openpgp/crypto-nettle")
#:cargo-inputs
(("rust-anyhow" ,rust-anyhow-1)
+ ("rust-async-generic" ,rust-async-generic-1)
("rust-capnp" ,rust-capnp-0.19)
("rust-capnpc" ,rust-capnpc-0.19)
("rust-dirs" ,rust-dirs-5)
@@ -210,9 +211,13 @@ than just headers; it requires tight integration with the MUA.")
("rust-lazy-static" ,rust-lazy-static-1)
("rust-log" ,rust-log-0.4)
("rust-paste" ,rust-paste-1)
- ("rust-sequoia-ipc" ,rust-sequoia-ipc-0.33)
- ("rust-sequoia-keystore-backend" ,rust-sequoia-keystore-backend-0.2)
- ("rust-sequoia-keystore-softkeys" ,rust-sequoia-keystore-softkeys-0.2)
+ ("rust-sequoia-directories" ,rust-sequoia-directories-0.1)
+ ("rust-sequoia-ipc" ,rust-sequoia-ipc-0.35)
+ ("rust-sequoia-keystore-backend" ,rust-sequoia-keystore-backend-0.6)
+ ("rust-sequoia-keystore-gpg-agent" ,rust-sequoia-keystore-gpg-agent-0.4)
+ ("rust-sequoia-keystore-openpgp-card" ,rust-sequoia-keystore-openpgp-card-0.1)
+ ("rust-sequoia-keystore-softkeys" ,rust-sequoia-keystore-softkeys-0.6)
+ ("rust-sequoia-keystore-tpm" ,rust-sequoia-keystore-tpm-0.1)
("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1)
("rust-thiserror" ,rust-thiserror-1)
("rust-tokio" ,rust-tokio-1)