summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 21:30:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:45 +0200
commitabc9f49abf54a677f9706b19207fed7552b8006a (patch)
tree9d8b3481dac203fd8f90bb0b4bf54327a4f3f36f /gnu/packages/sequoia.scm
parent65ebec369fadf783f2c7f585859f159aee144407 (diff)
gnu: Add rust-card-backend-0.2.
* gnu/packages/sequoia.scm (rust-card-backend-0.2): New variable. Change-Id: I94904d28d594aea0c24d31eaf44f5beab1d86132
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index c96da46e68..c06e9cf4d4 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -42,6 +42,27 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls))
+(define-public rust-card-backend-0.2
+ (package
+ (name "rust-card-backend")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "card-backend" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ra2zfcs0n4msw4j0hmv8f3bpfz49x5c704i93f6a844k2if6gmx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://gitlab.com/openpgp-card/openpgp-card")
+ (synopsis "Card backend trait, for use with the openpgp-card crate")
+ (description
+ "This package provides the card backend trait, for use with the
+openpgp-card crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-card-backend-pcsc-0.5
(package
(name "rust-card-backend-pcsc")