summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:14 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:10 +0200
commit8ca7d9eef713e0d6b19aa1d429ba125f2a592cb8 (patch)
treec38e06bac4e18941e2964ac00ec23a9068bf578f /gnu/packages/selinux.scm
parent1e41770dfe0f1e63298183392ef64bc30ab16049 (diff)
gnu: secilc: Drop xmlto workaround.
The xmlto error[1] was due to libsepol using an unversioned PUBLIC identifier for DocBook 4.2. [1]: <https://pagure.io/xmlto/blob/6fa6a0e07644f20abf2596f78a60112713e11cbe/f/FAQ> * gnu/packages/patches/libsepol-versioned-docbook.patch: New file. * gnu/local.mk: Register it. * gnu/packages/selinux.scm (libsepol)[source]: Apply it. (secilc)[arguments]: Drop xmlto workaround. [native-inputs]: Add docbook-xml-4.2. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I152dd7a30b2a310ed6589133bc98f5eef8a190a1
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index c45570744a..3fc88154fa 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -60,7 +60,8 @@
(file-name (git-file-name "selinux" version))
(sha256
(base32
- "1lcmgmfr0q7g5cwg6b7jm6ncw8cw6c1jblkm93v1g37bfhcgrqc0"))))
+ "1lcmgmfr0q7g5cwg6b7jm6ncw8cw6c1jblkm93v1g37bfhcgrqc0"))
+ (patches (search-patches "libsepol-versioned-docbook.patch"))))
(build-system gnu-build-system)
(arguments
(list
@@ -231,14 +232,6 @@ binary policies.")
(name "secilc")
(arguments
(substitute-keyword-arguments (package-arguments libsepol)
- ((#:make-flags flags)
- #~(let ((xsl (search-input-directory %build-inputs "xml/xsl")))
- (cons (string-append "XMLTO=xmlto --skip-validation -x "
- xsl "/docbook-xsl-"
- #$(package-version
- (this-package-native-input "docbook-xsl"))
- "/manpages/docbook.xsl")
- #$flags)))
((#:phases phases)
#~(modify-phases #$phases
(delete 'portability)
@@ -247,7 +240,7 @@ binary policies.")
(inputs
(list libsepol))
(native-inputs
- (list xmlto docbook-xsl))
+ (list docbook-xml-4.2 docbook-xsl xmlto))
(synopsis "SELinux common intermediate language (CIL) compiler")
(description "The SELinux CIL compiler is a compiler that converts the
@dfn{common intermediate language} (CIL) into a kernel binary policy file.")