summaryrefslogtreecommitdiff
path: root/gnu/packages/raspberry-pi.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 00:07:06 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:46 +0200
commit84728d5ba408c11344f78a6da50fd720d74e3c0a (patch)
tree5f03760563e687179744a7e28bc2355198eb135e /gnu/packages/raspberry-pi.scm
parenta9bd08f8f5012628a0f3c02e3cdb683c5ecec5b1 (diff)
gnu: Do not eagerly load (gnu packages commencement).
As its top comment says, this module is not meant to be imported to avoid circular module dependencies. * gnu/packages/chicken.scm (chicken) [propagated-inputs]: Resolve gcc-toolchain lazily. * gnu/packages/plan9.scm (plan9port): Likewise. * gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader) [native-inputs]: Resolve ld-wrapper lazily. Change-Id: Ie9859046ed32b67dc53bcc5444d6ae162e5d4022
Diffstat (limited to 'gnu/packages/raspberry-pi.scm')
-rw-r--r--gnu/packages/raspberry-pi.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/raspberry-pi.scm b/gnu/packages/raspberry-pi.scm
index c4f03c3ed9..216c74cb9c 100644
--- a/gnu/packages/raspberry-pi.scm
+++ b/gnu/packages/raspberry-pi.scm
@@ -28,7 +28,6 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bootloaders)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
@@ -196,7 +195,9 @@ Raspberry Pi. Note: It does not work on Raspberry Pi 1.")
("binutils" ,binutils)
("coreutils" ,coreutils)
("file" ,file)
- ("ld-wrapper" ,ld-wrapper)
+ ("ld-wrapper" ,(module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-wrapper))
("make" ,gnu-make)
("gcc" ,gcc-6)
("locales" ,(libc-utf8-locales-for-target))))