summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-13 16:57:59 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:07 -0400
commit2202f440e6aa3e96fe49f5fa0e67f3d30ea4f843 (patch)
treec8c616e8072017278ff03f09e9eafd38dff89c21 /gnu/packages/qt.scm
parent4605bc67d3df7b9e5942498d1c196664daaaef79 (diff)
gnu: qtdeclarative: Update to 6.6.2.
* gnu/packages/qt.scm (qtdeclarative): Update to 6.6.2. [arguments]<#:phases>: Disable flaky tst_qmltyperegistrar test. Disable failing tst_qquickiconimage test. * gnu/packages/patches/qtdeclarative-disable-qmlcache.patch: Adjust it. Change-Id: Ic7ddb603524ff07916d57b2ce92b7ffa407a5004 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index db5badb9385..74ea0472715 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1491,14 +1491,14 @@ with JavaScript and C++.")))
(define-public qtdeclarative
(package
(name "qtdeclarative")
- (version "6.5.2")
+ (version "6.6.2")
;; TODO: Package 'masm' and unbundle from sources.
(source (origin
(method url-fetch)
(uri (qt-url name version))
(sha256
(base32
- "06c7xfqn2a5s2m8j1bcvx3pyjqg1rgqkjvp49737gb4z9vjiz8gk"))
+ "0k6qndjvkkx3g8lr7f64xx86b3cwxzkgpl6fr6cp73s6qjkyk763"))
(patches (search-patches "qtdeclarative-disable-qmlcache.patch"))))
(outputs '("out" "debug"))
(build-system cmake-build-system)
@@ -1568,6 +1568,10 @@ with JavaScript and C++.")))
"("
(string-join
(list
+ ;; The 'tst_qmltyperegistrar' tests may fail
+ ;; non-deterministically (see:
+ ;; https://bugreports.qt.io/browse/QTBUG-123634).
+ "tst_qmltyperegistrar"
;; This test is marked as flaky upstream (see:
;; https://bugreports.qt.io/browse/QTBUG-101488).
"tst_qquickfiledialogimpl"
@@ -1610,7 +1614,11 @@ with JavaScript and C++.")))
"tst_dom_all"
"tst_qmlls"
"tst_qmllscompletions"
- ) "|")
+
+ ;; This test fails starting with 6.6.2 (see:
+ ;; https://bugreports.qt.io/browse/QTBUG-123748), for
+ ;; unknown reasons.
+ "tst_qquickiconimage") "|")
")")))))
(add-after 'install 'delete-installed-tests
(lambda _