summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-30 18:13:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:49 +0200
commitb18226c3a164c39d7ecfcc2a15043ee7e6e4d0bd (patch)
treebac48c7417455f3e917e8419370e21ca4615e85c /gnu/packages/python.scm
parent603a64920f13a28a5b62cb8aedf1f460f08e15f0 (diff)
gnu: python@3: Update to 3.6.3.
* gnu/packages/patches/python-3.5-fix-tests.patch: Rename to ... * gnu/packages/patches/python-3-fix-tests.patch: ... this. Adjust and disable more tests. * gnu/packages/patches/python-3.5-getentropy-on-old-kernels.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python.scm (python-2.7)[argument]: Patch '/bin/sh' in one more file. (python-3.5): Rename to ... (python-3.6): ... this. Update to 3.6.3. [source](patches): Remove obsolete patch, adjust to patch rename. (python-3): Use PYTHON-3.6.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7aba0833f0..94216fac67 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -203,6 +203,7 @@
'("Lib/subprocess.py"
"Lib/popen2.py"
"Lib/distutils/tests/test_spawn.py"
+ "Lib/test/support/__init__.py"
"Lib/test/test_subprocess.py"))
(("/bin/sh") (which "sh")))
@@ -328,23 +329,22 @@ data types.")
;; Current 2.x version.
(define-public python-2 python-2.7)
-(define-public python-3.5
+(define-public python-3.6
(package (inherit python-2)
- (version "3.5.3")
+ (version "3.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-fix-tests.patch"
- "python-3.5-fix-tests.patch"
- "python-3.5-getentropy-on-old-kernels.patch"
+ "python-3-fix-tests.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))
(sha256
(base32
- "1c6v1n9nz4mlx9mw1125fxpmbrgniqdbbx9hnqx44maqazb2mzpf"))
+ "1nl1raaagr4car787a2hmjv2dw6gqny53xfd6wisbgx4r5kxk9yd"))
(snippet
'(begin
(for-each delete-file
@@ -361,7 +361,7 @@ data types.")
"/site-packages"))))))))
;; Current 3.x version.
-(define-public python-3 python-3.5)
+(define-public python-3 python-3.6)
;; Current major version.
(define-public python python-3)