summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:44:55 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:44:55 +0000
commite8a8c5a13e475f628f90d2d358b6cc13e2faee4b (patch)
tree7c72e25324a8e2f711f6a291787a5093cea0e265 /gnu/packages/python-xyz.scm
parent2605de61e9bddde3d02f6eb9232df5705f4a29b9 (diff)
gnu: Add python-distance.
* gnu/packages/python-xyz.scm (python-distance): New variable. Change-Id: I0c8d98f39d779fcbcb5ce37bf64db118dfc0b4e4
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66716f33f4..614416e54a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -482,6 +482,29 @@ including arbitrary-length lists, records, mixed types, and missing data,
using NumPy-like idioms.")
(license license:bsd-3)))
+(define-public python-distance
+ (package
+ (name "python-distance")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Distance" version))
+ (sha256
+ (base32 "0la51nzzqrkisshwbk2wpviisqqzylwkz9qsa9f3y05nyn27b030"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (home-page "https://github.com/doukremt/distance")
+ (synopsis "Utilities for comparing sequences")
+ (description
+ "This package provides helpers for computing similarities between
+arbitrary sequences. Included metrics are Levenshtein, Hamming, Jaccard, and
+Sorensen distance, plus some bonuses. All distance computations are
+implemented in pure Python, and most of them are also implemented in C.")
+ (license license:gpl2+)))
+
(define-public python-jsonpath-ng
(package
(name "python-jsonpath-ng")