summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 20:56:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:41 +0000
commit8cbd7e9aa4733fc15e5e2e8252f952f7ccd92fd9 (patch)
tree859b0b989e898adf4891227756cd1b5152e4b272 /gnu/packages/python-xyz.scm
parentc4e1b63cc9dfc919c9444fb733731ba65ac690b1 (diff)
gnu: python-codespell: Update to 2.3.0.
* gnu/packages/python-xyz.scm (python-codespell): Update to 2.3.0. [arguments]<phases>: Add 'fix-pytest-config. [inputs]: Remove python-chardet. [propagated-inputs]: Add python-chardet. [native-inputs]: Remove python-flake8 and python-pytest-cov. [description]: Start from a new line, fix fill column. Change-Id: Id3eb7e1547f37fbf92de3eaf1a5bf58f79ba5905
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 23 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 468d3c61c7..0987cd9d60 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20874,35 +20874,43 @@ checking library.")
(define-public python-codespell
(package
(name "python-codespell")
- (version "2.2.5")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "codespell" version))
(sha256
- (base32 "0mmynpblhwbja0vmzbmbb9cgpxdl7b0lxaf9h2zr5dpddvgsv7vd"))))
+ (base32 "07s72zfxkznigqdc23k7jp9saq0hgq0gf2kjmmxzcrayyw87s31n"))))
(build-system pyproject-build-system)
- (inputs
- (list python-chardet))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-config
+ (lambda _
+ ;; Drop test coverage requirements.
+ (substitute* "pyproject.toml"
+ (("\"--cov=codespell_lib\",") "")
+ (("\"--cov-report=\",") "")))))))
(native-inputs
- (list python-flake8
- python-pygments
+ (list python-pygments
python-pytest
- python-pytest-cov
python-pytest-dependency
python-tomli
python-setuptools
python-wheel))
+ (propagated-inputs
+ (list python-chardet))
(home-page "https://github.com/codespell-project/codespell/")
(synopsis "Spellchecker for code")
- (description "Codespell fixes common misspellings in text files.
-It's designed primarily for checking misspelled words in source code,
-but it can be used with other files as well. It does not check for word
-membership in a complete dictionary, but instead looks for a set of
-common misspellings. Therefore it should catch errors like \"adn\", but
-it will not catch \"adnasdfasdf\". This also means it shouldn't
-generate false-positives when you use a niche term it doesn't know
-about.")
+ (description
+ "Codespell fixes common misspellings in text files. It's designed
+primarily for checking misspelled words in source code, but it can be used
+with other files as well. It does not check for word membership in a complete
+dictionary, but instead looks for a set of common misspellings. Therefore it
+should catch errors like \"adn\", but it will not catch \"adnasdfasdf\". This
+also means it shouldn't generate false-positives when you use a niche term it
+doesn't know about.")
(license
(list
; for codespell and codespell_lib