summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 20:19:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:40 +0000
commit8062b35b36c94ebd8b3c4a656cc65ad2b16e5631 (patch)
tree620b6a7cd6e2742e66588a80937e199e6ecbf2e6 /gnu/packages/python-xyz.scm
parentc3ec4641b337935d98ec8268f90821b6b3e51f39 (diff)
gnu: python-pep8-naming: Update to 0.14.1.
* gnu/packages/python-xyz.scm (python-pep8-naming): Update to 0.14.1. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use custom 'check. [native-inputs]: Add python-setuptools, and python-wheel. [description]: Adjust fill column. Change-Id: I6bb2cd30cad18518c91897070288c2872cad2a58
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a8461fa37..f56dff9073 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15099,21 +15099,32 @@ PEP 8.")
(define-public python-pep8-naming
(package
(name "python-pep8-naming")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pep8-naming" version))
(sha256
- (base32
- "1dc0b6xw1cxp01v9zsv4ryk49rfs1lngfpvzsixgp8b7z3ffcf4z"))))
- (build-system python-build-system)
- (propagated-inputs (list python-flake8))
+ (base32 "0dlapswhvzkkyw9gmjngc4rbzasdxnpxwj8mdkmmfmc7h2p2iwhy"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "run_tests.py")))))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-flake8))
(home-page "https://github.com/PyCQA/pep8-naming")
(synopsis "Check PEP-8 naming conventions")
(description
- "This package provides the @code{pep8-naming} Python module, a
-plugin for flake8 to check PEP-8 naming conventions.")
+ "This package provides the @code{pep8-naming} Python module, a plugin for
+flake8 to check PEP-8 naming conventions.")
(license license:expat)))
(define-public python-pep440