summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-11 10:48:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-11 13:03:33 +0300
commit556a96fe21e6b9d3e878f7cdb49b882646e55890 (patch)
tree01a5335afe27926dc9d5a617f3bfe8a1c1ef3263 /gnu/packages/python-xyz.scm
parent1b3b653aa0b69daf09535798d93a5acf773e9e69 (diff)
gnu: python-gevent: Remove cythonized files.
* gnu/packages/python-xyz.scm (python-gevent)[source]: Adjust snippet to also remove generated cythonized files. [native-inputs]: Add python-cython.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f4867ece01..c28b0675ad8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16127,7 +16127,27 @@ graphviz.")
(snippet
'(begin
;; unbunding libev and c-ares
- (delete-file-recursively "deps")))))
+ (delete-file-recursively "deps")
+ ;; Remove cythonized files.
+ (with-directory-excursion "src/gevent"
+ (for-each delete-file
+ (append (list "resolver/cares.c"
+ "queue.c"
+ "local.c"
+ "libev/corecext.h"
+ "libev/corecext.c"
+ "greenlet.c"
+ "event.c"
+ "_waiter.c"
+ "_tracer.c"
+ "_semaphore.c"
+ "_imap.c"
+ "_ident.c"
+ "_hub_primitives.c"
+ "_hub_local.c"
+ "_greenlet_primitives.c"
+ "_abstract_linkable.c")
+ (find-files "." "\\.html$"))))))))
(build-system python-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -16215,8 +16235,9 @@ graphviz.")
(propagated-inputs
(list python-greenlet python-zope-event python-zope-interface))
(native-inputs
- ;; For tests.
- (list python-dnspython python-psutil python-objgraph))
+ (list python-cython
+ ;; For tests.
+ python-dnspython python-psutil python-objgraph))
(inputs
(list c-ares libev))
(home-page "https://www.gevent.org/")