summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2025-01-01 01:26:09 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2025-01-01 01:26:09 +0300
commit48b4bfa7d1ec26c7c92ff53b66b50260b57abcb3 (patch)
tree542a3bbe34b539f5f6c29a16be077a4e166f4778 /gnu/packages/python-xyz.scm
parent1eefe5107526ee3ba991a7f0675b845c89d38c2b (diff)
gnu: python-ijson: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-ijson): Use pyproject-build-system. [arguments]: Remove. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I29ab71f63b1088bd7e0cf6e10a72a73ac7dcbc86
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 71cd840004..436358064c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -36700,24 +36700,15 @@ simple mock/record and a complete capture/replay framework.")
(uri (pypi-uri "ijson" version))
(sha256
(base32 "1sp463ywj4jv5cp6hsv2qwiima30d09xsabxb2dyq5b17jp0640x"))))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; the tests run by the default setup.py require yajl 1.x,
- ;; but we have 2.x. yajl 1.x support is going to be removed
- ;; anyway, so use pytest to avoid running the yajl1-related
- ;; tests. See: https://github.com/ICRAR/ijson/issues/55
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
(inputs
;; yajl is optional, but compiling with it makes faster
;; backends available to ijson:
(list yajl))
(native-inputs
- (list python-pytest))
- (build-system python-build-system)
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (build-system pyproject-build-system)
(home-page "https://github.com/ICRAR/ijson")
(synopsis "Iterative JSON parser with Python iterator interfaces")
(description