summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2025-01-01 20:09:01 -0600
committerjgart <jgart@dismail.de>2025-01-01 20:23:59 -0600
commit41dab04e17fe13f42151ff1003c6dc725896b117 (patch)
treec42d2c0505c056d111bf6df386f6b54ad81d5bcf /gnu/packages/python-xyz.scm
parentdff037f9aad74cf4457b552961cc66b0635dac4d (diff)
gnu: Add python-pylsp-mypy.
* gnu/packages/python-xyz.scm (python-pylsp-mypy): New variable. Change-Id: I4cf398df820fdcc91229bdafdc2d0cab6f5c01c1
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86ed1c9627..8641144a46 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3321,6 +3321,25 @@ approximate nearest neighbor search with Python bindings.")
Unicode-to-LaTeX conversion.")
(license license:expat)))
+(define-public python-pylsp-mypy
+ (package
+ (name "python-pylsp-mypy")
+ (version "0.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pylsp_mypy" version))
+ (sha256
+ (base32 "1amvqzb5lhhw2011003mwm88chb8sz5aax1jrqc3jg0jpak992fj"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (propagated-inputs (list python-mypy python-lsp-server))
+ (home-page "https://github.com/python-lsp/pylsp-mypy")
+ (synopsis "Mypy linter for the Python LSP Server")
+ (description
+ "Mypy linter integration for use with @code{python-lsp-server}.")
+ (license license:expat)))
+
(define-public python-pyls-black
(package
(name "python-pyls-black")