summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 22:18:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:41 +0000
commit261156bac28e355de0425d46bfd466b76f1a6b6a (patch)
treef7461e4ccc7d6a12c6b5b5e6e7212d61eaefdf5b /gnu/packages/python-xyz.scm
parentc7d8d7ab49ee0836743b1f72747915fcd1f00bbc (diff)
gnu: python-marshmallow: Update to 3.22.0.
* gnu/packages/python-xyz.scm (python-marshmallow): Update to 3.22.0. [native-inputs]: Remove python-flake8, python-flake8-bugbear, python-mypy, python-setuptools, and python-wheel; add python-flit-core. [description]: Start from a new line. Change-Id: Ib45c9bd921cba90c198cd8bdfc43023db99baf98
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f67869a496..747b40540d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26241,30 +26241,28 @@ input.")
(define-public python-marshmallow
(package
(name "python-marshmallow")
- (version "3.19.0")
+ ;; XXX: The latest version requires missing timezones from python-pytz
+ ;; which needs to be updated.
+ (version "3.22.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "marshmallow" version))
(sha256
- (base32
- "0y6vpq2p5841kcw2qil68la0rx9z1vmxzj3dxjv99kjhsq7jq0wh"))))
+ (base32 "0gl2qmq5sqf1b3f84zd7yzkznaknr6j5lnbxcfw0n8ja20lzawj9"))))
(build-system pyproject-build-system)
- (propagated-inputs
- (list python-packaging))
(native-inputs
- (list python-flake8
- python-flake8-bugbear
- python-mypy
- python-pytest
+ (list python-pytest
python-pytz
python-simplejson
- python-setuptools
- python-wheel))
+ python-flit-core))
+ (propagated-inputs
+ (list python-packaging))
(home-page "https://github.com/marshmallow-code/marshmallow")
(synopsis "Convert complex datatypes to and from native Python datatypes")
- (description "@code{marshmallow} provides a library for converting complex
-datatypes to and from native Python datatypes.")
+ (description
+ "@code{marshmallow} provides a library for converting complex datatypes
+to and from native Python datatypes.")
(license license:expat)))
(define-public python-marshmallow-jsonapi