summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:44:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-18 01:44:53 +0000
commit2605de61e9bddde3d02f6eb9232df5705f4a29b9 (patch)
tree4f486e0b4e7c81052a4cb89c05a5746bd167c931 /gnu/packages/python-xyz.scm
parentf96f094df25b663b1272bee9e31c468caf766b31 (diff)
gnu: Add python-pyxdameraulevenshtein.
* gnu/packages/python-xyz.scm (python-pyxdameraulevenshtein): New variable. Change-Id: I33b3bc5ec63c014fcca8b10623be0f5e0cf1eb91
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7eecfeb512..66716f33f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -508,6 +508,28 @@ comparison operators, as defined in the original
@url{http://goessner.net/articles/JsonPath/, JSONPath} proposal.")
(license license:asl2.0)))
+(define-public python-pyxdameraulevenshtein
+ (package
+ (name "python-pyxdameraulevenshtein")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyxdameraulevenshtein" version))
+ (sha256
+ (base32 "07nhds44ry9mchqjqjdnq2asp13y9pqc8003pkydvb3dah7wrvhv"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-cython
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/lanl/pyxDamerauLevenshtein")
+ (synopsis "Damerau-Levenshtein edit distance algorithm")
+ (description
+ "@code{pyxDamerauLevenshtein} implements the Damerau-Levenshtein (DL)
+edit distance algorithm for Python in Cython for high performance.")
+ (license license:bsd-3)))
+
(define-public python-xmldiff
(package
(name "python-xmldiff")