summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2025-01-01 01:05:15 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2025-01-01 01:05:15 +0300
commit1eefe5107526ee3ba991a7f0675b845c89d38c2b (patch)
treec48835eea6b09946c9df0f2571b7b8ded655c947 /gnu/packages/python-xyz.scm
parent60f89a2fe4e2de08838a4f923e89aea123a0a3c0 (diff)
gnu: python-face: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-face): Use pyproject-build-system. [arguments] <#:phases>: Simplify. Change-Id: I51d2224d025ea97eeef5a285c5ab2738dfbb87ee
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 68b1c42a40b..71cd840004f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,7 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2025 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -36553,7 +36553,7 @@ into a human readable HTML table representation.")
(uri (pypi-uri "face" version))
(sha256
(base32 "0gpd9f0rmbv3rd2szi2na37l29fabkwazikjrxc6wca1lddwlnbx"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -36562,12 +36562,11 @@ into a human readable HTML table representation.")
(when tests?
;; Make installed package available for running the tests.
(add-installed-pythonpath inputs outputs)
- ;; We must provide the full path to the Python binary
- ;; otherwise "test_search_prs_basic" test fails.
- (invoke (search-input-file inputs "/bin/python")
- "-m" "pytest" "-v")))))))
+ (invoke "pytest" "-v")))))))
(native-inputs
- (list python-pytest))
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-boltons))
(home-page "https://github.com/mahmoud/face")